TMnet
ISDN Guide Ver 0.3
Foreword
This guide is intended as an
introduction to ISDN as it applies to TMnet Support and Telekom Malaysia.
It covers the following topics:
ISDN
Introduction
ISDN stands for Integrated Services
Digital Network. It offers the following benefits to the customer:
However ISDN has the following
shortcomings
How
ISDN works
ISDN is very different from normal
PSTN phone lines.
A normal PSTN phone line uses
sound to transmit information, be it voice or data, over copper cables to
the nearest exchange. The quality of the sound is dependent on the condition
of the copper cable, the distance from the exchange and so on. PSTN was never
designed for data transmission, and so modems are needed for sound-to-electrical
signal conversion (analog to digital) conversion.
ISDN however, uses digital signals
to transmit information, be it voice or data, over copper cables to the nearest
exchange. Since the entire transmission channel is digital, it is much faster
and no analog to digital conversion takes place. It is also very tolerant
of line quality and not subject to unexpected disconnections.
Please examine the diagram below
to compare ISDN and PSTN.
Even though ISDN runs on standard
pair of copper wires, there are 3 virtual channels available to you:
You may use one or both B channels
for voice or data. Even though ISDN lines are digital, ISDN equipment normally
have one or 2 ports to allow you to connect analog telecommunications devices
such as phones, faxes and modems. Some ISDN phones even allow you to use all
3 channels for voice connections, although not simultaneously.
You can configure your ISDN equipment
to connect to the Internet using both B channels simultaneously. This is called
Multilink PPP, and it allows data transfer rates of up to 128kpbs.
ISDN
Line Application
You may apply for an ISDN line
at selected Kedai Telekom. Please note that ISDN service may not be available
in all areas, due to technical reasons.
The list of selected Kedai Telekom
and other pre-sale information is given here (http://www.tm.net.my/isdn.htm).
First you need to get the form
from the front counter.
Fill in your details in Section
1. For personal users, place your name as the Name of Company. Other fields
that need to be filled are Installation address, Post code, Contact person
and Telephone number.
Under Section 2, you need to
fill in the following information:
Under Section 2B - Type of Equipment
(CPE) to be connected, you need to tick the Terminal Adapter and Internet
Access boxes.
When the form is complete, submit
it to the clerk in charge. You can choose to be billed for installation when
the first monthly bill arrives.
ISDN
Line Installation
You may choose to convert your
existing line to ISDN, or you may specify a completely new installation. If
you choose to do the latter, you have to engage a Telekom contractor (list
available at Kedai Telekom) to install the line for you, and you will be charged
for the service.
In any case, when the Telekom
Malaysia CNO arrives, he will do the following:
The type of NT you get is dependent
upon which exchange you are connected to.Telekom Malaysia uses Ericsson, Fujitsu,
Motorola or NEC NTs. If you are not sure which type of NT you are using, please
ask the CNO. You need this information when reporting a fault to Telekom Malaysia's
Fault Reporting Service.
You will need a power source
for this NT at all times. The interface between the NT and the phone cable
is known as the U interface.
After testing the line, the CNO's
job is complete. The next step should be performed by a computer vendor.
ISDN
Terminal Adapter Installation
To connect your computer to the
NT, you need to use an ISDN Terminal Adapter (TA) or ISDN Router. The connection
between the ISDN TA or Router and the NT is knows as the S/T interface. Normally
the NT has two S/T interfaces, the other one will be used by Telekom Malaysia
CNOs for testing purposes.
Some NTs, like the NEC NT shown
here, have only one S/T interface.The other port is the connection to the
U interface.
Sometimes ISDN TAs are referred
to as ISDN modems. This is actually incorrect since no analog to digital conversion
takes place.
There are internal and external
models available. Internal ISDN TAs are installed into one of your computer's
slots. External ISDN TAs are typically connected to your computer's serial
port.
ISDN TAs have to be configured
before being used. For best results, configuration must be done by the Vendor.
The configurations involves setting the NT type, enabling MultilinkPPP, assigning
phone numbers to analog ports and so on.
Once this configuration is complete,
the TA may be treated just like an analog modem. It is controlled by standard
dialler software, such as Win95 DUN (Win95) or FreePPP (Mac). Win95 and Mac
configuration is almost the same as Dial 1515 except:
Even though you can achieve rates
of 128kpbs, the serial port on most PCs are limited to 115kpbs. You will need
a different serial card to achieve higher port speeds. Most new Macs, however,
can support 230kpbs as is.
Some TAs come with a built-in
NT. These TAs may be connected straight to the U interface, however this is
not recommended as Telekom Malaysia will not be able to guarantee network
connectivity. Always try to obtain TAs with S/T interfaces instead.
Most TAs have lights on them.
However not all the lights are standard. Here is the lights for the TA I tested:
The ports on TAs also differ
from TA to TA. Here are the ports for the TA I tested:
Please see the section on ISDN
configurations for more information.
ISDN
Router Installation
If you wish to connect a network
of computers to the NT, you need to use an ISDN Router. The connection between
the Router and the NT is knows as the S/T interface. Normally the NT has two
S/T interfaces, the other one will be used by Telekom Malaysia CNOs for testing
purposes.
ISDN Routers are typically connected
to a network hub via RJ45 Ethernet cables. You may also connect a single computer
to a Router by using an Ethernet cross cable (which enables you to utilise
to full speed of the ISDN line, since you are no longer limited by your serial
port speed.)
ISDN Routers have to be configured
before being used. For best results, configuration must be done by the Vendor.
The configurations involves setting the IP address of the router (usually
set to 200.200.200.201), NT type, enabling MultilinkPPP, routing phone numbers
to analog ports and so on. Once this configuration is complete, the TA may
be treated just like an router. Username and password for Internet services
are stored in the Router and not the computers connected to it. You need to
use the Network Control Panel (Win95) or TCP/IP (Mac) to set the router as
your internet gateway. The IP addresses will be something like 200.200.200.202,
203, and so on. Note that these IP addresses only exist behind the ISDN Router
and not seen outside, so some Internet services such as ICQ may not work.
Some Routers come with a built-in
NT. These TAs may be connected straight to the U interface, however this is
not recommended as Telekom Malaysia will not be able to guarantee network
connectivity. Always try to get Routers with S/T interfaces instead.
Most Routers have lights on them.
However not all the lights are standard. Here is the lights for the Router
I tested:
The ports on Routers also differ
from Router to router.. Here are the ports for the Router I tested:
ISDN
configurations
A typical ISDN TA installation
is shown here. Note that the Network Terminator also requires a power supply.
A Typical ISDN Router installation
for one computer via Ethernet cross cable is shown here.
Actual photo of a similar configuration
to that shown above. No analog devices are connected. The Cross cable is red.The
black box is the NT's power supply and grounding terminal. The ISDN router's
power supply is not in the picture.
A typical ISDN Router installation
to a computer network is shown here.
Problems
Encountered During Testing
These are problems I encountered
after approximately one month of testing with a 3Com Impact TA. Review unit
courtesy Micro Village, 03 - 705 1686.
Cause:
D channnel is only used to set up the line. After that, it is no longer used.
Solution:
If you have an analog phone connected to the TA, pick up the receiver and
the D channel will reactivate.
Cause:
Many possible causes, but normally can only be fixed by a vendor or Telekom
Malaysia.
Solution:
Please check to see if you can still make voice calls. If you can't, you need
to report the fault to Telekom Malaysia's Fault Reporting Service. Dial 100
and inform them of your name, phone number and type of NT.
If you
can make voice calls, chances are your line is OK, but your TA is faulty.
Inform the TA vendor.
If your
TA is fine, check your username and password with TMnet Support.
Cause:
This happens when Multilink PPP is enabled and only one B channel is authenticated.
Solution:
Disconnect and reconnect again. You may have to do this a few times to connect
successfully.
Cause:
This happens during when you are connected and there is no activity.
Workaround:
Start a file download. As long as the file is being downloaded (there is activity),
you will not be disconnected.
Cause:
This is due to the fact the the FTP server will perform reverse lookups to
confirm identity and will disallow transactions if reverse lookup fails.
Solution:
Please inform TMnet Support of this matter, and we will forward it to the
proper department.
Cause:
Improper disconnection, such as shutting down the computer while connected.
Solution:
Reset the ISDN TA. You can do this by switching it off and on again, or pressing
the reset button.
Cause:
Incorrect TA configuration
Solution:
Ask the vendor to reconfigure the ISDN TA.
Cause:
Incorrect TA configuration
Solution:
Ask the vendor to reconfigure the ISDN TA.
Cause:
Faulty NT.
Solution:
Ericcson NTs have 2 lights, Power and Line. If only the Power light is on,
the NT is faulty. Motorola NTs typically have 2 lights on. If only one light
is on, the NT is faulty.
Call
Telekom Malaysia Fault Reporting Service by dialling 100. Give your particulars
and the type of NT you are using. Telekom Malaysia CNO will replace your NT
and/or troubleshoot your line.
Contact
Information
For sales and marketing information,
please fax 03-7038665 (Attn: Marketing Dept.) and for any ISDN information
please fax 03-7042204, (Attn: Corporate Technical Support).
If you have problems with the
line, up to and including the NT, please contact Telekom Malaysia's Fault
Reporting Service by dialling 100.
If you have problems with any
of the following, please contact the ISDN Vendor.
If you require Technical Support,
please call 1-800-88-INET (1-800-88-4638) or fax 03-704 2204/03 704 2885.
Technical Support's responsibility is the following: